SRS Ordering- SRS is currently experiencing issues ordering through the Roof Hub Integration, SRS is actively working to resolve the issue.

Incident Report for GiddyUp System Status

Resolved

This incident has been resolved.
Posted Sep 09, 2026 - 10:47 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 09, 2026 - 10:44 EDT

Investigating

SRS Ordering- SRS is currently experiencing issues ordering through the Roof Hub Integration, SRS is actively working to resolve the issue.
Posted Sep 09, 2026 - 10:32 EDT
This incident affected: Third Party Integration (SRS Distribution's Roof Hub).